Pocketpedia issues

Report your bugs here - if someone else has already mentioned the same bug, just add on to their post with as much info as possible to make the hunting easier.

Pocketpedia issues

Postby danco » Tue May 09, 2017 2:53 pm

I have the latest version of Pocketpedia on the latest iOS, but I don't use my iPad very often.

I recently tried to open Pocketpedia's Bookpedia database, and every time I tried opening Library just took me back to the iPad Home screen. The Pocketpedia CDPedia Library and DVDPedia Library opened fine, as did Bookpedia's Borrowed collection. I do have around 4800 books in the library.

In addition (though this may be just a glitch in my wifi network) when I tried to sync Bookpedia, the sync of covers got stuck after around 800 covers (I believe they had all been synced before).
danco
Addicted to Bruji
Addicted to Bruji
 
Posts: 94
Joined: Fri Aug 31, 2007 3:06 pm

Re: Pocketpedia issues

Postby Conor » Wed May 10, 2017 3:25 am

Thanks for the bug report. You can try removing the Bookpedia collection and doing a brand new sync. Swipe left on "Bookpedia" in the home screen of Pocketpedia. It will then present the delete option. Could be a brand new sync takes care of the bug, otherwise if you don't mind could you please send me your Bookpedia database. You will find the database in your data folder located in your home folder at ~/Library/Application Support/Bookpedia/Database.bookpd. Under Yosemite you must use the Finder "Go" menu and hold down the option key and select the "Library" option. Once there navigate to Application Support/Bookpedia and select Database.bookpd and use the "Compress" command under the main "File" menu. This will create a .zip version that you can then attach to an email message. It's likely small I can then fix if I can reproduce it.
User avatar
Conor
Top Dog
 
Posts: 4687
Joined: Sat Jul 03, 2004 12:58 pm

Re: Pocketpedia issues

Postby danco » Thu May 11, 2017 1:56 am

OK, I think I can see why there is an issue, there must have been a change in the Pedias that I had not kept up with.

I tried deleting and resyncing, and the covers appeared to sync, but I still had the same issue.

However, I realise that my Pedia databases are not where you said. For some reason (way back when) my databases are in a folder that I set up as a subfolder of my Documents folder, and seem to work ok there. In Application Support, I do have a Bookpedia folder (and CDPedia and DVDPedia folders), but it just contains two folders, Covers and Plugins (which are empty), and two files, Database.pediadata and autofill.xml.

I should probably move the databases back where they are supposed to be, even though they work where they are. How should I do that?
danco
Addicted to Bruji
Addicted to Bruji
 
Posts: 94
Joined: Fri Aug 31, 2007 3:06 pm

Re: Pocketpedia issues

Postby danco » Thu May 11, 2017 2:50 am

I seem to have cracked it. Export database from where it was (inside a subfolder of documents). Open Bookpedia with OPtion key, and choose default database. Import the exported database, and now I have it in its default location. Sync and all went well.

But that still leaves the question as to whether syncing should have taken place even with the database not in its default place. Certainly the CDPedia and DVDPedia databases appear to have synced even with non-standard locations.
danco
Addicted to Bruji
Addicted to Bruji
 
Posts: 94
Joined: Fri Aug 31, 2007 3:06 pm

Re: Pocketpedia issues

Postby Conor » Thu May 11, 2017 9:04 am

Thanks for trying that out, glad the move was able to fix it. It's likely not the location but the import/export procedure. I do know that macOS, unlike instructed, does split the database file into a working section and a on disk section. Although rare, when in this mode it can't be transferred to Pocketpedia, but a restart of DVDpedia normally forces macOS to merge those two files. Your move of data folder would have certainly done that. I'll move my data folder out of the Library and find out if I can reproduce it.
User avatar
Conor
Top Dog
 
Posts: 4687
Joined: Sat Jul 03, 2004 12:58 pm


Return to Bug Reports

cron