MyFancyIndex HTML export not working in Chrome

Report your bugs here - if someone else has already mentioned the same bug, just add on to their post with as much info as possible to make the hunting easier.

MyFancyIndex HTML export not working in Chrome

Postby rbianchi » Fri Apr 07, 2017 1:34 pm

Hi Conor,

Have a problem when I make an export with MyFancyIndex.
If I open it with Chrome and I click on a book, It does not show the book details. I see only a horizontal bar without any data and the 'X' to close.
It works with Firefox and Safari.

I am using BookPedia 5.5.1 on iMac with OSX 10.11.6 (El Capitan)

Coul you help me to resolve this problem?
rbianchi
Junior Member
Junior Member
 
Posts: 2
Joined: Fri Apr 07, 2017 1:23 pm

Re: MyFancyIndex HTML export not working in Chrome

Postby Conor » Fri Apr 07, 2017 10:44 pm

I'll take a look over the weekend and let you know, if I am able to unravel the mystery.
User avatar
Conor
Top Dog
 
Posts: 5104
Joined: Sat Jul 03, 2004 12:58 pm

Re: MyFancyIndex HTML export not working in Chrome

Postby Conor » Sun Apr 09, 2017 12:22 pm

Is this loading from a web server or directly from a file on the hard drive? As I know Chrome can act very differently when loading local resources.

I have been unable to repeat it, here is a test page.

Do try the beta versions, I have gone ahead and updated all the JavaScript and Colorbox plugin that is being used to the latest versions.
User avatar
Conor
Top Dog
 
Posts: 5104
Joined: Sat Jul 03, 2004 12:58 pm

Re: MyFancyIndex HTML export not working in Chrome

Postby rbianchi » Mon Apr 10, 2017 9:29 am

Hi Conor,
Is loading from a file on the hard drive.
Beta version have the same problem.
Here is a screen capture of Chome console:
https://www.dropbox.com/s/9u5trjy64ih29 ... 2.png?dl=0
rbianchi
Junior Member
Junior Member
 
Posts: 2
Joined: Fri Apr 07, 2017 1:23 pm

Re: MyFancyIndex HTML export not working in Chrome

Postby Conor » Mon Apr 10, 2017 9:47 am

Thank you. Chrome decided not to load files from the hard drive. So the javascript does not load that does the window. It will work once online as the request is then "https", instead of "file". If you need it to work from the hard drive, you would need to move all the jquery.js file and colorbox.js file inline into the single HTML page.
User avatar
Conor
Top Dog
 
Posts: 5104
Joined: Sat Jul 03, 2004 12:58 pm

Re: MyFancyIndex HTML export not working in Chrome

Postby nik@tiad » Mon Jan 07, 2019 1:40 pm

Hi again!

I already posted in an earlier thread but since I am having the exact same problem i just wanted to reply to this quickly.

I will just be using the file offline/from harddrive. It seems that you, Conor, did find the problem, but I haven't fully understood what to do exactly.

In Chrome and Safari i see only the horizontal bar without any data and the 'X' to close - as the thread opener. In firefox the colorbox shows me the details, but not the cover image.
I can see both image and details when i open in another tab though. But then the layout isn't that nice :-)

"If you need it to work from the hard drive, you would need to move all the jquery.js file and colorbox.js file inline into the single HTML page"

Could you give me a little more info on how that would be done?

Thanks so much!

Nik
nik@tiad
Contributor
Contributor
 
Posts: 5
Joined: Mon Dec 10, 2018 1:59 pm

Re: MyFancyIndex HTML export not working in Chrome

Postby nik@tiad » Tue Jan 08, 2019 7:07 am

okay problem solved, sorry that was stupid haha..

still don't get why it doesnt work in safari or chrome here; but firefox looks good!
nik@tiad
Contributor
Contributor
 
Posts: 5
Joined: Mon Dec 10, 2018 1:59 pm

Re: MyFancyIndex HTML export not working in Chrome

Postby Conor » Thu Jan 10, 2019 11:27 am

Glad you were able to solve it. I think it might be the local setup as they display correctly here. But having all the different bits installed locally, it's hard to simulate what it would be like on a computer without all the files loaded. Glad to hear Firefox is doing the correct thing.
User avatar
Conor
Top Dog
 
Posts: 5104
Joined: Sat Jul 03, 2004 12:58 pm


Return to Bug Reports

cron