Item count display for smart collections

Report your bugs here - if someone else has already mentioned the same bug, just add on to their post with as much info as possible to make the hunting easier.

Item count display for smart collections

Postby demiadirac » Wed May 22, 2019 12:53 pm

Hi,
I noticed a funny effect about the display of the item count of smart collections: After opening Bookpedia, for one of my smart collections a low number is displayed (1027). I open the collection, and immediately the number jumps to 1033; when I close and restart Bookpedia it is back to 1027. Pocketpedia always shows 1027. The correct number is 1033. It happens in the productive Bookpedia as well as in the beta versions.
Is this effect known?
Yours, demiadirac.
demiadirac
Addicted to Bruji
Addicted to Bruji
 
Posts: 27
Joined: Sat Jun 14, 2014 5:32 am

Re: Item count display for smart collections

Postby demiadirac » Sun Jun 23, 2019 12:08 pm

The behavior persists with the new productive version of Bookpedia. I find it a bit of a nuisance.
demiadirac
Addicted to Bruji
Addicted to Bruji
 
Posts: 27
Joined: Sat Jun 14, 2014 5:32 am

Re: Item count display for smart collections

Postby Conor » Sun Jun 23, 2019 1:37 pm

Thanks for updating me. Could you please send me your Database.bookpd file so I can try to reproduce the problem here. I did check for this and the code looks clean. But If I start using your file and I can get it happening to me, then it's easier to track down the bug.

You'll find the file in your Home folder under ~/Library/Application Support/Bookpedia/Database.bookpd. Please archive the file before sending it to save space. (Select it and choose 'Archive' or 'Compress' from the File menu. That'll create a new file called 'Database.bookpd.zip' which you can then attach to the email.)

The Library folder is hidden by default so to go to your Bookpedia data folder you have to use the Finder's 'Go' menu, hold down the Option key and the Library folder will appear.
User avatar
Conor
Top Dog
 
Posts: 5194
Joined: Sat Jul 03, 2004 12:58 pm


Return to Bug Reports

cron