Titles Starting with Pronoun "I" Incorrectly Sorted

Report your bugs here - if someone else has already mentioned the same bug, just add on to their post with as much info as possible to make the hunting easier.

Titles Starting with Pronoun "I" Incorrectly Sorted

Postby kennedyrt » Sat Jul 11, 2020 4:22 pm

Titles starting with pronoun "I" are incorrectly sorted. For example, the title "I Love Dinosaurs" is incorrectly sorted into the "L"s and not into the "I"s. "I" is neither a definite nor an indefinite article so it should not be ignored during a sort.

This problem occurs in both DVDpedia 6.0.1 and DVDpedia 6.0.2.
kennedyrt
Bruji Friend
Bruji Friend
 
Posts: 17
Joined: Wed Jan 18, 2012 11:43 pm

Re: Titles Starting with Pronoun "I" Incorrectly Sorted

Postby FineWine » Sat Jul 11, 2020 6:29 pm

For total control over the sort feature, use the 'Sort Title' field. Ensure it is activated within Preferences > Fields > Add Edit Panel. Whatever you enter into that field, that's what the program will take into account when sorting. So in your case you want "I Love Dinosaurs" to be sorted under "I" instead of "Love", so enter I into the Sort Title field of the movie. The program will automatically resort this title for you.

Also please have ago at the latest Beta. You can download from here: https://bruji.com/beta/ DVDpedia Beta 6.0.3 Beta167.
User avatar
FineWine
Addicted to Bruji
Addicted to Bruji
 
Posts: 601
Joined: Wed May 28, 2008 2:41 am
Location: Tauranga, New Zealand

Re: Titles Starting with Pronoun "I" Incorrectly Sorted

Postby duncancreamer » Tue Feb 02, 2021 10:05 pm

This doesn't seem to work for me. My The Animatrix is nestled between Appleseed and Angel Cop, but I want it living between (or at least near) The Matrix and The Matrix Reloaded.
duncancreamer
Junior Member
Junior Member
 
Posts: 3
Joined: Sun Jan 31, 2021 9:39 pm

Re: Titles Starting with Pronoun "I" Incorrectly Sorted

Postby FineWine » Tue Feb 02, 2021 11:32 pm

From the Help file: https://bruji.com/help/dvdpedia/configure/preferences.html#general

Preferences > General > Ignore foreign articles during title sort

Ticking this setting the program will now not take into account foreign articles such as der, die, das, le, la, el, etc. when sorting entries by title. The program automatically ignores English articles (the, a, an) when sorting. For this setting to take effect you have to re-sort the title column after you've checked the preference so the titles can pick up the new sort method.

So in your case you what to UNTICK this setting. Apologises for not making this clear in my first post. :oops:

For total control over the sort feature, use the 'Sort Title' field. Whatever you enter into that field, that's what the program will take into account when sorting. So if you want "12 Monkeys" to be sorted under Monkey instead of 12, enter M into the Sort Title field of the movie.

Also have a read of this Help file: Sorting a collection

Let us all know how you get on.

Stay safe in these troubling times.
User avatar
FineWine
Addicted to Bruji
Addicted to Bruji
 
Posts: 601
Joined: Wed May 28, 2008 2:41 am
Location: Tauranga, New Zealand


Return to Bug Reports

cron