MAS update versions 6.0 in OS X 10.11

Any trouble you encounter with the Pedias, here's the place to ask for help.

MAS update versions 6.0 in OS X 10.11

Postby joseluismen » Thu Jun 20, 2019 5:37 am

I use two iMacs from 2007, with Mac OS X 10.11. I have installed versions 5.6.1 from the Apple Mac App Store. Today the updates to the versions 6.0 are available to me but only when reading that it was not compatible with systems previous to 10.12 I have not followed.
Going to the page of the applications, they keep appearing as compatible with 10.9, although in the description in the section of the new it is again indicated that they are not compatible with anything before 10.12
I visit then the web of bruji, and they already warn of the requirements of 10.12 for all versions 6.0. To check I have downloaded the demos, and I see the sign of prohibited in all of them.
If so, why does MAS offer me the update if it is not compatible with the installed system?
I love that they offer the new version for free to old users, of course. But it should only be installed if it is really compatible.
Greetins,

Jose Luis

P.S. Mechanically translated text since unfortunately I do not speak English. I apologize if I do not understand correctly what I meant.
joseluismen
Junior Member
Junior Member
 
Posts: 4
Joined: Sun Jan 17, 2010 8:35 am

Re: MAS update versions 6.0 in OS X 10.11

Postby DanThe » Thu Jun 20, 2019 6:33 am

I have a MBP that I bought in 2013 and I have seen some apps in the App Store that say "Will not run on this MacBook Pro" plus the buy/download button is greyed out. So there is no way to accidently purchase or downloading it.

Conor: Is this something that needs to be triggered within the app itself so that the App Store can detect the app requirements?
DanThe
Addicted to Bruji
Addicted to Bruji
 
Posts: 102
Joined: Tue Jan 05, 2016 6:23 pm

Re: MAS update versions 6.0 in OS X 10.11

Postby joseluismen » Thu Jun 20, 2019 8:45 am

Hi, no.
This happens when the application has not yet been acquired. Normally MAS alerts the user.
I speak of who has already acquired the program, and in the updates tab version 6 appears as an available update. In that case, in addition, if you do not make the system keeps warning that there are pending updates. I think there is a way to hide the program, but I do not know if it can be reversed if I upgrade in the future with another machine.
In addition, this means that you can not reinstall the compatible version unless you have backup copies. I, personally, have already become accustomed to making copies in disk images of each program that wants to reinstall in the future. Of many, I even keep different versions. As I just did with the versions 5.6.1 I had installed, in case the system is updated without being able to avoid it. In such cases, Apple has made it impossible to return to a functional version. And its reason: EVERYONE has Time Backup active, obviously :-) And it's one of the reasons why I have not paid anything in MAS for several years. Or they give me the possibility to acquire it directly and be responsible for my backup copies or in many cases, I do not buy.
joseluismen
Junior Member
Junior Member
 
Posts: 4
Joined: Sun Jan 17, 2010 8:35 am

Re: MAS update versions 6.0 in OS X 10.11

Postby Conor » Thu Jun 20, 2019 9:04 am

Thank you for the bug report. The MAS should be picking up the minimum system requirement from inside the program and not showing it on old systems. I'll resubmit the MAS version and make sure the minimum system requirement is listed correctly. I do know older App Store such as 10.6 and 10.7 have issues knowing the correct minimum system version but 10.11 should know it.

Thank you for the timely warning, lets me avoid issues with other users that will blindly and correctly assume to download the update and then the App will not run on their system. With a .0 release I always end up at .0.3 release in a few weeks. :)
User avatar
Conor
Top Dog
 
Posts: 5238
Joined: Sat Jul 03, 2004 12:58 pm

Re: MAS update versions 6.0 in OS X 10.11

Postby joseluismen » Thu Jun 20, 2019 9:30 am

Hi, thanks for taking it into account.
As I insinuated before, I am finding quite a few applications with similar problems: either they do not correctly mark the requirements and it appears as an update, or the new versions released mainly since November, many applications do not run correctly. In many cases, due to lack of necessary libraries.
Thanks,

Jose Luis
joseluismen
Junior Member
Junior Member
 
Posts: 4
Joined: Sun Jan 17, 2010 8:35 am


Return to Support

cron